Установка NetBeans IDE на Linux и JDK 1.7

Установка NetBeans IDE на Linux и JDK 1.7

Установка NetBeans IDE на Linux и JDK 1.7

1. Перед установкой IDE NetBeans 7.2.1 на Linux (Elementary OS) установим Oracle JDK.

Идем на сайт Oracle (http://www.oracle.com/technetwork/java/javase/downloads/index.html) и скачиваем нужную перейдя по  кнопке "JDK Download". Вот прямая ссылка на список пакетов jdk: http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html (возможно ссылка уже не работает). Я скачал Linux x64 (jdk-7u10-linux-x64.rpm).

2. Теперь его необходимо установить, для этого переконвертируем его в deb.

Для этого установим alien.
sudo apt-get install dpkg-dev debhelper build-essential
После установки заходим через терминал в папку с rpm пакетом и конвертим:
sudo alien jdk-7u10-linux-x64.rpm --script
В результате вы получите примерно следующее сообщение jdk_1.7.009-1_amd64.deb generated и появится соответственно файл jdk_1.7.009-1_amd64.deb. Все запускаем его и устанавливаем. Скачать уже deb пакет с версией 1.7.008 для x64 можно здесь (2.12.2012).

3. Скачиваем NetBeans

Заходим на сайт NetBeans: http://netbeans.org/downloads/ выбираем нужную и скачиваем. Я выбрал полную (netbeans-7.2.1-ml-linux.sh).

4. Запустим установку

sh netbeans-7.2.1-ml-linux.sh
Следуем инструкции по установки:
картинка 1
В результате вы получите нормальную, рабочую версию NetBeans:
картинка 1


Fatal error: require_once(): Failed opening required '/var/www/u1393462/data/www/4abv.ru/bitrix/webcraft-api/module/inc.php' (include_path='.:') in /var/www/u1393462/data/www/4abv.ru/bitrix/templates/alexb/footer.php on line 761